[PATCH] mxc: Fix pad names for imx51

Amit Kucheria amit.kucheria at canonical.com
Fri Jun 4 10:09:59 EDT 2010


On 10 Jun 04, Amit Kucheria wrote:
> On 10 Jun 04, Sascha Hauer wrote:
> > On Thu, Jun 03, 2010 at 08:05:44PM +0800, Jason Wang wrote:
> > >  
> > > -#define MX51_PAD_GPIO_1_22__UART3_RXD	IOMUX_PAD(0x630, 0x240, 3, 0x0, 0, NO_PAD_CTRL)
> > > -#define MX51_PAD_GPIO_1_23__UART3_TXD	IOMUX_PAD(0x634, 0x244, 3, 0x0, 0, NO_PAD_CTRL)
> > > +#define MX51_PAD_GPIO_1_22__UART3_RXD	IOMUX_PAD(0x630, 0x240, IOMUX_CONFIG_ALT1, 0x9f4, 4, MX51_UART3_PAD_CTRL)
> > > +#define MX51_PAD_GPIO_1_23__UART3_TXD	IOMUX_PAD(0x634, 0x244, IOMUX_CONFIG_ALT1, 0x0, 0, MX51_UART3_PAD_CTRL)
> > 
> > Urgs, there really is something wrong here.
> > 
> > First of all, this define should be named MX51_PAD_UART3_RXD__GPIO_1_22
> > as it describes the pad UART3_RXD in GPIO_1_22 mode. This seems to be
> > wrong with many (all?) defines in this file. Amit, you should have read
> > the comment ontop of this file which you copied from the i.MX35 part:
> 
> I'll admit that I was not completely conversant with the naming scheme then.
> All the GPIO-related names have been reversed. The others seem fine.
> 
> > /*
> >  * The naming convention for the pad modes is MX51_PAD_<padname>__<padmode>
> >  * If <padname> or <padmode> refers to a GPIO, it is named
> >  * GPIO_<unit>_<num> see also iomux-v3.h
> >  */
> 
> There was a comment below this:
> /*
>  * FIXME: This was converted using scripts from existing Freescale code to
>  * this form used upstream. Need to verify the name format.
>  */
> 
> I obviously reversed the naming for all the GPIO pads.
> 
> > This should be fixed before doing any other change to this file.
> 
> I'm preparing a patch now.
> 

Please find the patch attached.

You can see the output of diff without the whitespace changes here:
http://paste.ubuntu.com/444628/




More information about the linux-arm-kernel mailing list