[PATCH 1/2] arm: Replace CONFIG_HAS_TLS_REG with HWCAP_TLS and check for it on V6

Jamie Lokier jamie at shareable.org
Thu Jul 1 13:40:51 EDT 2010


Tony Lindgren wrote:
> +static void __init kuser_get_tls_init(unsigned long vectors)
> +{
> +	/*
> +	 * vectors + 0xfe0 = __kuser_get_tls
> +	 * vectors + 0xfe8 = hardware TLS instruction at 0xffff0fe8
> +	 */
> +	if (tls_emu || has_tls)
> +		memcpy((void *)vectors + 0xfe0, (void *)vectors + 0xfe8, 4);
> +}

Just a little opinion: Perhaps has_tls_reg would be a clearer name.
All variants "have TLS" after all.

Also - and this isn't directly related to your change so feel free to
ignore it - wouldn't it make more sense for the tls_emu case to use
the memory version (and update the memory location), so that even on
tls_emu systems, user programs which call the kuser code will run faster?
With that change, there would be no real penalty to enabling tls_emu
for any system that finds it useful.

-- Jamie



More information about the linux-arm-kernel mailing list