libertas_sdio ad-hoc problems when WEP was previously associated

Bogdan Radulescu bogdan at
Thu Nov 8 11:19:18 EST 2012

Hi everybody,

I am having issues with the libertas_sdio driver in all the kernels I
tried (3.0.4, 3.2.33, 3.4.14).
On kernel 3.6.6 the driver worked very unreliable so we will forget
about it for now.

My platform is ARM v5l, I'm not sure exactly what marvel chip is using
for wireless, but the libertas_sdio driver uses the 9.70.20p0

Basically the issue is that after I connect to a WEP network, I can't
create an ad-hoc network that works.
The network seems to be configured correctly (iwconfig shows expected
output), but it doesn't respond to ping.

I can replicate this bug 100% with all the linux tools available for
configuring the wireless (wpa_supplicant, iw, iwconfig) so it seems to
be the kernel and not the userpace which is buggy.

To replicate the issue you have to do this:
1. Connect a WEP network
2. Disconnect
3. Create an ad-hoc network
After this pinging the other end of the ad-hoc network doesn't work

To successfully create an ad-hoc network I should either reboot and
start with ad-hoc or associate to a WPA network and then disconnect
and create the ad-hoc network again.
Somehow, associating with a WPA network seems to reset the "damage"
done by the associating with WEP.

I would be happy to provide debug output but I wasn't able to obtain
anything usefull.

A related issue seems to be described since last year in this post:

I would appreciate some feedback,

More information about the libertas-dev mailing list