libertas_sdio firmware loading freezes the machine

Tomasz Sterna tomek at
Sun May 22 18:40:30 EDT 2011


I have a netbook which uses Marvell SD8686 connected with SDIO.

With no firmware in /lib/firmware libertas_sdio loads fine and reports
that it cannot find the firmware.

But when I put sd8686.bin and sd8686_helper.bin to /lib/firmware and
load the module, my machine completely freezes. To the point that it
leaves no trace of the problem in /var/log/messages.

I have set the following line in /etc/modprobe.d/libertas.conf:
options libertas libertas_debug=0xffffffff
to get some debugging, but since the machine freezes completely dead in
the moment the module is loaded, I cannot get anything usefull.

I tried many versions of firmware, and once got some messages printed to
dmesg that the firmware was loaded and machine froze during scannning.
But it's not reproducible - after the reboot with the same firmware it
froze the same way as with other attempts.

I tried 2.6.39, and kernels and the behavior does not
change - freeze without any panic or anything right the moment the
libertas_sdio module is loaded. Machine does not reboot, or gets black.
It just gets completely unresponsive.

Do you have any ideas what could I try next to debug the problem?

Tomasz Sterna
Instant Messaging Consultant : Open Source Developer

More information about the libertas-dev mailing list