CMD22(CMD_802_11_DATA_RATE)failure problem

Dan Williams dcbw at
Fri Aug 29 12:35:48 EDT 2008

On Fri, 2008-08-29 at 13:40 +0000, Cliff Cai wrote:
>  Hi all,
>  I'm porting a Murata SDIO wifi module(Marvell 8686) to my BF548-EZKIT,
>  libertas driver is the latest one in kernel 2.6.26 tree,firmware version 9.70.3p24.

Hmm, 2.6.26 only tries DATA_RATE if setting the rate via rate adaptation
fails.  It'll never try to get the data rate via DATA_RATE at all.  I
just checked on 2.6.27 and DATA_RATE never gets sent on card insertion.

>  After loading the driver modules,eth1 appears,but there are two CMD failures as following:
>  libertas_sdio: Libertas SDIO driver
>  libertas_sdio: Copyright Pierre Ossman
>  firmware: requesting sd8686_helper.bin
>  firmware: requesting sd8686.bin
>  libertas: 00:13:e0:a2:67:aa, fw 9.70.3p24, cap 0x00000303
>  libertas: unidentified region code; using the default (USA)
>  libertas: PREP_CMD: command 0x0022 failed: 2
>  libertas: PREP_CMD: command 0x00a3 failed: 2
>  libertas: PREP_CMD: command 0x00a3 failed: 2

These (the 0x00a3) should be harmless.

>  libertas: eth1: Marvell WLAN 802.11 adapter
>  CMD22 is  used to set data rate,so when I run" iwconfig eth1",it shows that bit rate is 0.
>  and "iwconfig eth1 rate auto" also failed

It'll show the data rate as 0 until you transmit or receive some frames,
because the rate isn't actually known until (a) you've associated to
something and (b) you've tx/rxed some frames.

Setting the rate to auto shouldn't fail though, sounds like a bug.  But
this looks like it's fixed in 2.6.27, no error is returned.

What's the git commit hash of the version of libertas you're using?
2.6.26 vanilla?

>  eth1      IEEE 802.11b/g  ESSID:""
>            Mode:Managed  Frequency:2.412 GHz  Access Point: 00:00:00:00:00:00
>            Bit Rate:0 kb/s   Tx-Power=18 dBm
>            Retry limit:8   RTS thr=2347 B   Fragment thr=2346 B
>            Encryption key:off
>            Power Management:off
>            Link Quality:0  Signal level:0  Noise level:0
>            Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>            Tx excessive retries:0  Invalid misc:0   Missed beacon:0
>  I'm able to run:
> >ifconfig eth1 up
> >iwlist eth1 scan
>  and get the available AP information.
>  also I successfully run
> >iwconfig eth1 essid  myAPname

Does the AP use any encryption?  Does an "iwconfig" show a valid BSSID
for the AP after you've tried to associate?  Just need to make sure the
card got a successful association to the AP.

If that all doesn't work, then we can try to dig a bit deeper.

>  But it seems eth1 doesn't work,when I set a static IP to eth1, pinging AP fails.
> >ifconfig eth1 myip
> >route add default gw mygateway
> >ping mygateway
>  ping statistics shows that several packets transmitted but got 0 packets.
>  I also set the same static IP to my PC,everything is OK.
>  I think it has something to do with the failure of CMD22.
>  Any idea is appreciated.
>  Best Regards
>  Cliff Cai
> _________________________________________________________________
> 一点即聊,MSN推出新功能“点我!”
> _______________________________________________
> libertas-dev mailing list
> libertas-dev at

More information about the libertas-dev mailing list