[PATCH] libertas: rename escape_essid() to _escape_essid() in assoc.c

Andres Salomon dilinger at debian.org
Thu May 17 00:30:46 EDT 2007

Jeff Garzik wrote:
> Andres Salomon wrote:
>> Hi,
>> I just committed this to olpc-2.6; it should probably be in the libertas
>> tree as well.  Pavel noticed that including both libertas and the 80211
>> stack made things blow up.
>> ------------------------------------------------------------------------
>> >From 3ecd1083f2e095172f0b69f0082ed41ff58a3a84 Mon Sep 17 00:00:00 2001
>> From: Andres Salomon <dilinger at debian.org>
>> Date: Tue, 8 May 2007 15:28:55 -0400
>> Subject: [PATCH] libertas: rename escape_essid() to _escape_essid() in assoc.c
>> We took escape_essid from the 80211 stack so that we wouldn't have to include
>> it (until there's a generic 80211 lib), but there are name conflicts if both
>> modules are included.  Thanks to Pavel Machek for pointing that out.
>> Aside from renaming it, I've also made it static (since it's not used outside
>> of assoc.c) and updated the comment describing its origin.
>> Signed-off-by: Andres Salomon <dilinger at debian.org>
> seems like the correct fix is to depend on the code in the upstream 
> kernel, not avoid it.

Of course; the rename fix was designed to be temporary.  Dan had a
reason for libertas having its own copy of the function (I forget what
it was, though).

More information about the libertas-dev mailing list