[LEDE-DEV] Routing two interfaces on same subnet

Aaron Z aczlan+ledev at gmail.com
Tue Jul 5 10:54:03 PDT 2016


On Tue, Jul 5, 2016 at 1:33 PM, Baptiste Clenet <bapclenet at gmail.com> wrote:
> Wifi and ethernet are in client mode.
> pseudo bridge with relayd? Can you describe a bit?
Here is how I do it on a Nanostation M2Loco:
#/etc/config/network
config interface 'lan'
        option type 'bridge'
        option stp '1'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '10.0.200.225'
        option gateway '10.0.200.254'
        option dns '10.0.200.38'
        option netmask '255.255.255.0'
#/etc/config/wireless
config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWRT'
        option encryption 'psk2'
        option key 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
        option network 'lan'

That creates a "br-lan" interface with the ip of 10.0.200.225 and ties
it to the "eth0" network as well as the "OpenWRT" interface on the
"radio0" radio.

Aaron Z



More information about the Lede-dev mailing list