[PATCH v7 07/12] PCI: Refactor matching logic for pci_dev_acs_ops

Pasha Tatashin pasha.tatashin at soleen.com
Fri Jul 17 15:02:35 PDT 2026


On Fri, 10 Jul 2026 21:26:10 +0000, David Matlack <dmatlack at google.com> wrote:
> Refactor the logic to match devices to pci_dev_acs_ops by factoring out
> the loop and device matching into its own routine. This eliminates some
> duplicate code between pci_dev_specific_enable_acs() and
> pci_dev_specific_disable_acs_redir(), and will also be used in a
> subsequent commit to check if a device requires device-specific
> enable_acs() during a Live Update.
> 
> [...]

Reviewed-by: Pasha Tatashin <pasha.tatashin at soleen.com>

-- 
Pasha Tatashin <pasha.tatashin at soleen.com>



More information about the kexec mailing list