Kernel Crash on starting hostapd

ravin goyal ravirocks1021 at
Tue Feb 14 23:06:17 PST 2017

Hi Rafal

As you have mentioned I have looked up for my wifi hardware , it is
supported by brcmfmac.

I am using Ampak AP6212 wifi hardware which is listed as part of
brcmfmac following link:

I have inserted the brcmfmac module manually using modprobe but my
wlan0 interface is linked with bcmdhd when I removed it I don't see
wlan0 in ifconfig
and when i re-insert it again and starts hostapd, it starts but it
didn't broadcast the ssid and afterwards I tried to re-insert bcmdhd
with op_mode=2 and starts hostapd again and it displayed the ssid this
time (which i am currenly doing)

It means hostapd is directly communicating with bcmdhd ,what does it
has to do with brcmfmac
Moreover on the given link they didn't provide the name of the driver
ap6212 is using. but it follows brcmfmac mainline kernel.


On 15 February 2017 at 11:20, Rafał Miłecki <zajec5 at> wrote:
> On 15 February 2017 at 05:39, ravin goyal <ravirocks1021 at> wrote:
>> It was running successfully but after some time I stopped it and tried
>> to run again in daemon mode it returns segmentation fault following
>> kernel crash message.
>> link:
>> I reboot the device and on boot it starts and it is working fine for
>> atleast now.
>> Any help appreciated?
> Driver you use is bugged. Nothing to do with hostapd. Contact Broadcom
> or try debugging & fixing your cfg80211.c (source file of driver you
> use).
> If this chipset is supported by brcmfmac you may try using it and in
> case of problem contacting linux-wireless mailing list.
> --
> Rafał

More information about the Hostap mailing list