WPA Supplicant, Ad-Hoc network WPA-PSK with Raspberry Pi 3

Stefan Ott hostap at desire.ch
Thu Oct 27 17:42:12 PDT 2016

Hi Greg

On Fri, Oct 28, 2016 at 01:12:30AM +0100, Greg Gigon wrote:
> Hi All
> I tried many forums and this mailing list is my last hope.
> I am trying to setup secure wireless ad-hoc network between 2 Raspberry Pi’s 3 using their on board Wireless chip.

I just spent several days getting this to work (on different
hardware though), maybe I can help. In my case there were
two main issues:

- My wireless card tried to do encryption in hardware but
  did so poorly. Disabling hardware encryption (nohwcrypt
  for the ath9k module) fixed that. Maybe your driver has a
  similar option?
- More importantly, several of the Linux distributions
  involved (one was Gentoo, the other one an
  openembedded-based system) had wpa_supplicant compiled
  without IBSS_RSN support. Since your logs never mention
  IBSS_RSN this might be the issue in your case. You can
  enable IBSS_RSN by adding it in wpa_supplicant's .config
  file before compiling.

Your configuration looks good (it's basically identical to
mine, except for the ssid and psk).

Good luck.

Stefan Ott

More information about the Hostap mailing list