failure using wpa_supplicant from command line

Jouni Malinen j at
Sun Oct 9 06:59:36 PDT 2016

On Tue, Oct 04, 2016 at 03:54:48PM +0300, Gucea Doru wrote:
> The problem is that the scanning for new networks is issued only after SIGHUP:
> - If I start wpa_supplicant with wpa_supplicant -Dnl80211 -iwlan0
> -c./ap.conf the scan process is not started;
> - If I send SIGHUP to the wpa_suplicant process then the scan process
> is started the connection to the AP specified in the configuration
> file is successful.
> I just want wpa_suppllicant to start the scan process without sending
> a SIGHUP. Does the Android framework use any addition parameter for
> wpa_supplicant in order to issue the scan command?

The Android Wi-Fi framework issues SCAN commands and takes care of
network selection based on scan results. A separate command (e.g.,
SELECT_NETWORK) is then used to request a connection.

> I also tried to start wpa_supplicant from comman line with the same
> configuration files used by the Android framework but the problem
> persists.

It is still not clear to me what this "problem" is. What you describe
here sounds like the expected behavior on Android..

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list