WPA2-PEAP problems

Harshal Chhaya harshal
Wed May 25 04:16:41 PDT 2011


I can connect to hostapd in WPA2-PEAP using my Win7 laptop.

I also found that my target client (an embedded system) uses EAPOL
version1 and PEAP v0 when it successfully authenticates with another
AP (using freeRADIUS as the backend). I used the 'hostapd.conf' file
to set eap_version=1 and used the 'eap_users' file to specify PEAPv0.
Still no success. )-8

I understand that these are older protocol versions but are they fully
supported in hostapd? Jouni?

I don't want to edit the hostapd source to work around these problems
(i.e. ignore the length mismatch etc.) but I am running out of ideas
to try.

Any suggestions welcome.

- Harshal

On Wed, May 25, 2011 at 2:00 AM, Ed W <lists at wildgooses.com> wrote:
> On 24/05/2011 19:44, Harshal Chhaya wrote:
>> Try setting 'eap_version' to 1 (instead of 2) and 'wmm_enabled' to 0
>> (the default is 1) since that seems to help in some cases (not in my
>> case though).
> I already tried eap_version=1, but not sure on the other param. ?So far
> I haven't seen any successful auth (trying only OSX and iPad clients
> though). ?Do you see some successful auth? Which type of client?
> Cheers
> Ed W

More information about the Hostap mailing list