How to get debugging output? Prob with AP and wistron CM9

Ed W lists
Tue Aug 16 02:51:04 PDT 2011

Hi, I am having some problems getting any debugging info out of hostapd
0.7.3 (uclibc+busybox) when there are some kind of startup issues

For example I had a working setup with an ath 5414 card and two bss.  I
swapped the card for a CM9 and at that point hostapd exits at startup
with no output (neither syslog nor console)?

I tried strace, but I didn't see anything that looked like an error (but
not sure what I should look for)

Finally I tried disabling the additional bss in my config file and now
hostapd bursts into life...

I'm having a similar problems while trying to get a working config, eg I
changed the wpa_passphrase to something innocuous and again I got the
same symptoms - no output, just fails to startup?

Q: Is there some other way to get debug output when hostapd has problems
starting up? (I'm already using -dd on the command line, and debugging
at max in the config file)

Q: Does someone know if it's a documented limitation of the CM9
(ath5213a I think?) that it doesn't support multiple BSS? Any opinions
on the CM9 vs ath5414 cards? (I have had some success with Compex
WLM54SAG23, considering Wistron DCMA81?)

Thanks for any hints

Ed W

More information about the Hostap mailing list