Prism 2.5 based access point disappear after a while

Paolo paolo
Sun Mar 30 09:29:01 PDT 2008

On Sun, 30 Mar 2008 18:19:18 +0300
Jar <jar at> wrote:

> Paolo wrote:
> > I flashed the card with  1.1.1/1.8.2 and also tried the 1.1.4/1.8.2
> > combination with no difference :(
> Can you try with 1.1.1/1.7.4?

Well, i tried to flash first with the volatile version but something
went wrong, it freezed the machine. I then retried checking the command
carefully, and yet the same.

So then i tried with the non volatile version, and i did first
prism2_sram -v, getting this:

# prism2_srec -v 1.8.2/PK010101.HEX 1.8.2/SF010802.HEX
S3 CRC-16 generation record: start=0x007E1800 len=65536 prog=1
Start address 0x00000000
srec summary for SF010802.HEX
Component: 0x001f 1.8.2 (station firmware)
Supported platforms:
  0x800a 1.0.0,  0x800b 1.0.0,  0x800c 1.0.0,  0x800d 1.0.0,  0x8012
1.0.0 0x8013 1.0.0,  0x8014 1.0.0,  0x8016 1.0.0,  0x8017 1.0.0,
0x8018 1.0.0 0x801a 1.0.0,  0x801b 1.0.0,  0x801c 1.0.0,  0x8021
1.0.0,  0x8022 1.0.0 0x8023 1.0.0
Interface compatibility information:
  role=Supplier variant=2 range=1-15 iface=Station Firmware-Driver (4)
  role=Actor    variant=1 range=1-1 iface=Modem-Firmware (1)
  role=Actor    variant=2 range=1-1 iface=Controller-Firmware (2)
  role=Actor    variant=1 range=4-4 iface=Primary Firmware-Driver (3)
Separate S3 data areas:
S3 area count: 3
  addr=0x007E1800..0x007EEAEF (len=54000)
  addr=0x007F0800..0x007F17FF (len=4096)
  addr=0x007FE000..0x007FECD1 (len=3282)
Total data length: 61378
Start address 0x00000000

ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
Missing wlan component info
Could not read wlan RIDs

obviously the device is there, the module is loaded, and dmesg shows
correctly the infos like the firmware is 1.8.2 and so on..
So i guess i screwed up somehow and fu**ed the card?

Maybe the card was a bit broken even before?
anyways to do flashing i followed jun sun howto page, and everything
went fine until today..

Hope it's not broken , but i think it's a sign i gotta get an atheros
one :)
It upset me too much i cant lower the txpower.. and moreover atheros
card i read are supposed to have good RF hardware which allow better
trasmission ever at longer distance (or at  lower power, and they are

More information about the Hostap mailing list