Nokia E65, E51 problem and Solution - connection to AP with bridge, madwifi, and hostap

jar at jar
Mon Mar 10 23:46:32 PDT 2008

Sven Nielsen wrote:
> Found the solution.
> Problem was that Nokia E65 / E51 would associate with AP and everything
> worked fine using _no_ encryption, but the phones were not reachable
> when using encryption, although browsing and initiating calls from phone
> was fine.
> Solution was, of course, easy ;-), but not being a total network guru,
> it took me some time to find the right parameters. Also, I first did not
> think it to be a settings problem since using no encryption everything
> worked perfectly, so I thought it was a bug using encryption. :-(

I have also some difficulties with my e51. Usually (when the e51 and 
hostap AP has been on several days) I can't connect and the dmesg shows:

wifi0: decryption failed (SA=00:1c:xx:xx:xx:xx) res=-4
wifi0: decryption failed (SA=00:1c:xx:xx:xx:xx) res=-4
wifi0: decryption failed (SA=00:1c:xx:xx:xx:xx) res=-4

After restart the hostap AP PC and/or e51 (I don't know which one did 
the magic) I can connect to AP and the conection then works. I can't see 
similar dmesg warning messages with other clients.

I use prism2.5 pci card with 1.74 firmware in my AP. Both auth/enc. 
methods (WPA/WPA2, TKIP/AES) are enabled in my hostapd.conf.

Best regards, Jar

More information about the Hostap mailing list