802.11a support

Nils Bagge nbagge
Fri Aug 29 13:43:52 PDT 2008


I am working with the ath9k device driver (consequently using
driver_nl80211, I am not yet sure of all the terminology), and have
recently been able to get hostapd to work nicely in 802.11g mode. I just
tried putting the NIC in 802.11a mode and encountered an error, which
eventually led me to the following code:

hw_features.c: hostapd_get_hw_features(), ~ line 81: 
feature->channels[j].flag &= ~HOSTAPD_CHAN_W_SCAN

Being unfamiliar with this code, it is not yet entirely clear to me the
purpose of HOSTAPD_CHAN_W_SCAN, or furthermore any of the channel flags
themselves CHAN_W_XXXX flags. 

Regardless, that flag (HOSTAPD_CHAN_W_SCAN) needs to be set in order for
the desired channel to be configured. I saw a TODO in the code about
adding regulatory domain lookup. Does the setting of this flag depend on
regulatory domain? After seeing this code, it would seem like 802.11a
support in hostapd has never worked! I just turned the bit on, and was
able to start moving data in 11a.


More information about the Hostap mailing list