wpa-ttls connection problems

samuel samuel.verstraete
Tue Aug 19 11:43:57 PDT 2008

On Tue, Aug 19, 2008 at 8:02 PM, Jouni Malinen <j at w1.fi> wrote:
> On Tue, Aug 19, 2008 at 02:51:21PM +0200, samuel wrote:
>> My university has a wireless network and they handed out instructions
>> to connect to the network for windows and macosx...
>> These are the instructions for the osX connection:
>> http://helpdesk.ugent.be/ugentnet/UGentWPA_MACOS.pdf
>> **I have tried to translate this in what i think should be a correct
>> wpa_supplicant config... still it doesn't seem to be able to connect:
> Your configuration looks fine to me and seems to match with what is
> described in the instructions for OS X.
>> **this is the log when i turn on extreme logging:
>> http://merlin.ugent.be/log
> This seems to show successfully started EAP-TTLS handshake. However, the
> authentication server behavior on processing the first EAP-TTLS packet
> from the peer is odd. It tries to start EAP-PEAP at that point which is
> not allowed change at that point in EAP handshake.. Would you happen to
> know which authentication server is used?

I have absolutely no idea...  But i guess i could ask them...

but i do know that the university network has PEAP access as well...
but I was told that one is less stable than TTLS...
I do have instructions for NetworkManager in Ubuntu for the PEAP thingy... :

i've "translated" those instructions as well... to no avail...


i get pretty much the same error actually....

> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap

More information about the Hostap mailing list