wired 802.1X authorization for Asus wl500gx router

Jouni Malinen jkmaline
Tue Feb 13 19:20:09 PST 2007

On Mon, Feb 12, 2007 at 12:38:38AM +0100, Mikhail Kostousov wrote:

> My provider required 802.1X authorization with dynamic WEP keys for wired
> network. I've got it from my desktop computer, with next config:

Dynamic WEP keys for wired network?? I've never heard of anyone using
WEP on wired network nor am I aware of any driver supporting such a

> ap_scan=0
> network={
>        key_mgmt=IEEE8021X WPA-EAP

WPA-EAP should not be here; WPA is only used with wireless networks.

>        eap=PEAP
>        phase2="auth=MSCHAPV2"
>        identity= (my user)
>        password= (my password)

I would assume the dynamic WEP part is bogus and you would need to add
eapol_flags=0 to make wpa_supplicant not wait for dynamic keys.

> With command:
> wpa_supplicant -ieth0 -Dwired -c wpa_supplicant_wired.conf -dd
> After that I compiled wpa_supplicant for my router, and tried to do such
> thing with router. I got following log:
> Initializing interface 'vlan1' conf 'wpa_supplicant.conf' driver 'wired'

This does not match with your command line above (eth0 vs. vlan1). Which
one it is? Is this with a created from eth0?

> I've tried to compare log of router and of desktop, and I found that
> difference begin from line "EAPOL: idleWhile --> 0". Desktop doesn't have
> this line. It has "RX EAPOL from 00:15:62:a3:53:86".
> I cannot understand, why it happens on router. I am using the same
> configuration of wpa_supplicant, the same configuration of compilation
> (exclude options for CC compiler).

Are you using the same ethernet configuration (vlan vs. no vlan)?

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list