Not using modified module

ahuguet at ahuguet
Wed Apr 11 03:54:14 PDT 2007


after manually copying the .ko files on
/lib/modules/ to
/lib/modules/ and
restarting the machine, the messages were shown.

Is there any way to achieve this, without having to manually copy the
files each and every time?

Maybe if I run:
> 1) make -C /usr/src/linux-source-2.6.17 SUBDIRS=`pwd` modules
> 2) make -C /usr/src/linux-source-2.6.17 SUBDIRS=`pwd` modules_install
> 3) depmod -ae

while being in
/lib/modules/ the
resulting module files would overwrite the old ones?

Seems that the kernel loads modules
from/lib/modules/ so I
always need this folder to contain the latest modules.

Thanks again for your help, I'm step to step closer to a complete
resolution of this affair.

> Greetings,
> I've edited hostap_80211_rx.c file.
> I added this instruction:
> printk(KERN_DEBUG "I've received a packet");
> Just after hdrlen = hostap_80211_get_hdrlen(fc); on void hostap_80211_rx
> function.
> I've saved the changes to the file.
> The file is located on
> /usr/src/linux-source-2.6.17/drivers/net/wireless/hostap
> I've compiled it following the instructions obtained in this mailing list.
> Being superuser:
> 1) make -C /usr/src/linux-source-2.6.17 SUBDIRS=`pwd` modules
> 2) make -C /usr/src/linux-source-2.6.17 SUBDIRS=`pwd` modules
> 3) depmod -ae
> I've then setup a machine that has a card using hostap, as master.
> I've set up another machine as managed, and sending UDP packets to the
> master.
> I expected that, running dmesg on the master machine should give me lots
> of messages with "I've received a packet" but got none, though the UDP
> packets are being sent (I can see using ifconfig that lots of packets are
> being received, and increasing everytime I run it)
> I suspect that this happens because the card is not using the modified
> hostap module, with the printk instruction in it. Otherwise I cannot
> understand why the debug messages aren't shown when using dmesg command.
> I've tried unloading the hostap and hostap_cs modules, both with modprobe
> -r and rmmod, but it says they're in use.
> I'm using a PC card connected to a PCI slot through an adaptor.
> I'd like to know how to make the system use the newly compiled modules,
> for I think it's still using the default ones.
> Thanks for your help.
> _______________________________________________
> HostAP mailing list
> HostAP at

More information about the Hostap mailing list