problems connecting to AP using WPA-PSK, Linux 2.6.16, ipw2200 card (wext driver)

Ivan Tarasov ivan.tarasov
Tue Jul 18 11:49:15 PDT 2006


I've got persistent problems with using wpa_supplicant to connect to an AP
with WPA authentication. I did an extensive search on mailing lists and
Internet in general and didn't find any solution, although I've seen a lot
of reports of similar problems.

/etc/wpa_supplicant.conf contents is somewhat like this:

# the following 3 lines were changed and this configuration was the most

The access point is Linksys WRT54G. The WiFi card is Intel IPW2200. I tried
using both wpa_supplicant 0.4.8 and 0.5.4. The attached log is from 0.5.4,
it shows both the unsuccessful attempts to connect to the AP and a
successful attempt, which disconnected mysteriously at last. It seems that
most often situation is that after wpa_supplicant started ASSOCIATING it
receives the 0x8b15 event with AP address 00:00:00:00:00:00, and thus it
simply blacklists the AP.

You might be interested looking at the following lines more thoroughly:
lines 840-965: wpa_supplicant started authenticating, but suddenly received
the 0x8b15 during the 4WAY_HANDSHAKE, which it considered to be the sign of
a wrong password, thus it got disconnected.
lines 1142-1261: same as above, but it passed the 4WAY_HANDSHAKE and
received the 0x8b15 event with zero AP address during the GROUP_HANDSHAKE.
lines 1855-2035: successful connection, I was able to work for some time and
everything worked fine until it received the 0x8b15 event with zero AP
address again.

I tried hacking the sources in some ways but it didn't really help.

I tried connecting to this access point from Windows (using the application
from the Intel driver pack, without wpa_supplicant) and the connection was
very stable and it didn't drop (and it connected almost immediately). While
I was recording the attached log another notebook was connected to the same
access point and had a stable connection (again, from Windows). No changes
were made to the access point configuration during the log recording, so no
side effects could be introduced this way.

I would appreciate any help on this, I can give more information and try
recording more logs (but they all are pretty similar to the one I attached
anyway), or try patching the source if you direct me.

PS: sorry for resending, I forgot to compress the log the first time
Best regards,
Ivan Tarasov
-------------- next part --------------
An HTML attachment was scrubbed...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: supplicant.log.gz
Type: application/x-gzip
Size: 4512 bytes
Desc: not available
Url : 

More information about the Hostap mailing list