In-kernel-hostap does not find pccard on soekris4511

Klaas De Craemer klaasdc
Mon Jul 3 09:11:06 PDT 2006


I'm trying to configure my soekris4511-board as a freeradius-server/AP
but I have some trouble getting my Senao NL2511 to work with hostap.
I have already tried the Debian-mini-distro Pebble, which has kernel
2.4. wlan0 is correctly detected in it, but hostapd complains that it
can't interface with the kernel. So i decided to built a complete new
rootfs from scratch based on kernel , in which I enabled
hostap and hostap_cs as a module.
Now, I can load and unload the module(s) (I also tried the PCI and PLX
modules...) as much as I want, nothing is detected.
"ifconfig wlan0 up" keeps saying:
wlan0: ERROR while getting interface flags: No such device

Dmesg also doesn't output anything useful, only the confirmation of the loading:
hostap_pci: 0.4.4-kernel (Jouni Malinen <jkmaline at>)
hostap_cs: 0.4.4-kernel (Jouni Malinen <jkmaline at>)
hostap_plx: 0.4.4-kernel (Jouni Malinen <jkmaline at>)

Compiling everything in the kernel also yields no result.
Something else I noticed is that the LED on the pc-card goes green
when the PCMCIA-support starts. Normally, it's supposed to stay dark
until after the driver has loaded and wlan0 is enabled...

Klaas De Craemer

More information about the Hostap mailing list