Ndiswrapper +wpa_supplicant

Andrew Duane andrew
Sun Nov 21 09:14:33 PST 2004


All I changed was to remove scan_ssid from the configuration file and it

If you need me to post anything else about my config let me know so it can
help others.

To summarise I use ndiswrapper 0.11 wpa_supplicant 0.2.5 with Linux 2.6.9
kernel on Fedora distro. With a linsys wrt54g ap/router and a linksys wmp54g
pci card.

With the following .config:


And my wpa_supplicant.conf:

# allow frontend (e.g., wpa_cli) to be used by all users in 'wheel' group
# home network; allow all valid ciphers

Thank you very much for your help.

-----Original Message-----
From: hostap-bounces+andrew=duaneville.com at shmoo.com
[mailto:hostap-bounces+andrew=duaneville.com at shmoo.com] On Behalf Of Jouni
Sent: 21 November 2004 16:31
To: hostap at shmoo.com
Subject: Re: Ndiswrapper +wpa_supplicant

On Sun, Nov 21, 2004 at 01:13:17PM -0000, Andrew Duane wrote:

> Also here is what is returned from iwlist wlan0 scan:
> wlan0     Scan completed :
>           Cell 01 - Address: 00:0C:41:9D:F4:4A
>                     ESSID:"Foundation"
>                     Protocol:IEEE 802.11b

> Extra:wpa_ie=dd160050f20101000050f20201000050f20201000050f202
> A bit odd it says that the protocol is 802.11b as I have it set to only
> accept 802.11g???

That's fine, nothing is using that information. I would assume
ndiswrapper does not try to map the supported rates information into
IEEE 802.11b vs .11g. The main information is here: scan seems to work
and it returns wpa_ie.

Previous message:

> I'm running version 0.11 of ndiswrapper and 0.2.5 of wpa_supplicant.
> I tried the ndis 0.12rc3 cvs but it errors when I compile.

Please use the CVS snapshot, not the 0.12rc3 prerelease. At least the
version from yesterday worked in my tests whereas 0.12rc3 required some
fixing for Linux 2.4.28 (but worked with the minor changes I did).

> Once I get:
> Failed to initiate AP scan.
> It just hangs there. There are no subsequent messages

That's odd.. wpa_supplicant should scan again after five seconds. Could
you please re-test with -ddd on wpa_supplicant command line to enable
all debug messages.

> "I saw similar issues with a scan for
> specific SSID (scan_ssid=1), but broadcast SSID scan worked fine."
> What value needs to be in my conf file to broadcast? I just followed the
> instructions.

Just leave that scan_ssid line out from the configuration and test

Jouni Malinen                                            PGP id EFC895FA
HostAP mailing list
HostAP at shmoo.com

More information about the Hostap mailing list