wpa_supplicant fails with ndiswrapper andmadwifi driver for Atheros 802.11a/b/g card

Jouni Malinen jkmaline
Wed Nov 3 19:30:42 PST 2004

On Sun, Oct 31, 2004 at 10:38:39PM -0800, Michael Reilly wrote:

> I have a Cisco CB21AG card which is based on the Atheros 802.11a/b/g chip 
> (5212 I think it is called).  The card has a PCI id of vendor 0x168c, 
> device 0x0013.
> wpa_supplicant fails when I try to use WPA-PSK.  I downloaded a trial copy 
> of driverloader and it works fine.

Which NDIS driver are you using?

> The debug from wpa_supplicant indicates that the AP scan returns 0 bytes. 
> No suitable AP is found.  I am not sure where the problem lies except that 
> it fails with both ndiswrapper and the madwifi drivers pulled from the 
> madwifi project's cvs last wednesday.

Can you get scan any results with 'iwlist wlan0 scan'? Can you use
ndiswrapper in plaintext mode with the same AP?

> What debugs should I obtain in order to solve this problem?  I ran 
> wpa_supplicant with the -dd command line option and saw that the sacn 
> failed.  (Sorry I lost the log I captured.  I will recreate it later and 
> post it as a followup to this message.)

That would be suitable log file for hostap (i.e., wpa_supplicant)
mailing list.

> I am using wpa_supplicant 2.5 and ndiswrapper 0.10 (I tried ndiswrapper 
> 0.11 but the perl script prints out a number of error messages so went back 
> to version 0.10).  The access point is a Cisco 1100.

Which firmware version is used in the AP? I haven't tested ndiswrapper
with Cisco APs, but wpa_supplicant and Atheros-based cards have worked
nicely with Cisco APs.

On Mon, Nov 01, 2004 at 08:46:12AM +0100, Wouter de Jong wrote:

> Does anyone else have this up and running with an Atheros-chip ?

Yes, worked fine with ndiswrapper the last time I tested (a long time
ago, though).

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list