Problems in combination: Bridging and HostAP driver.

Dennis Jansen Dennis.Jansen
Fri Jul 30 03:02:18 PDT 2004

Hi Brian,

thanks for your answer, but just waiting and following your setup didn't seem 
to solve the problem. In my setup they are both Linuxes.
I will further explain my setup:


And I can wait as long as I want, on Ethereal I only see:
ACK asks: who is
ACK asks: who is
ACK asks: who is
(...) [no quote]
it just doesn't get answers. And the ACKs from .1.1 asking for .1.24 aren't 
even received.
And I can ping back and forth on eth1 no problem.

And if I remove wlan0 from the bridge again it work immediately.
I tried removing the ips from the interfaces and everything. So if you got the 
bridge working, please tell me what version of hostap with what network 
driver you are using, and I'll see if it makes a difference for me.
I tried assigning the wlan MAC to the bridge, but only get 
"ERROR: Can't change MAC: interface up or not permission: Operation not 
supported" from macchanger.

Hoping for some more help...


> Wait a few minutes and see if you can ping it. This is especially true if
> you have a router between you and the box.  You may want to clear the ip of
> both interfaces before bringing the bridge up. Here is my setup:

More information about the Hostap mailing list