IRQ'S Bugging me!! Help!!

Brian Sturgill zen_hacker
Fri Jul 23 18:03:41 PDT 2004

What pcmcia controller does the laptop have and what version of the kernel 
are you running. If it is a later 2.4 kernel and a newer laptop, it probably 
should be running the yenta_socket driver for pcmcia.  I have an older 
laptop that was a real bugger to get the card services working in Linux. I 
couldn't use the yenta_ socket driver. I had to pass some boot options to 
the kernel when booting to make mine work but it was older hardware (P200mmx 
laptop). I noticed your /proc/interrupts was showing the i82365 driver. You 
may try the yenta_socket driver and see what happens.

Let me know some more info and I may be able to help you


>From: "gaurav dawra" <openapproject at>
>To: vda at
>CC: hostap at
>Subject: IRQ'S Bugging me!! Help!!
>Date: Fri, 23 Jul 2004 23:45:43 +0000
>:) Thanx Denis , i have seen the fireworks, well these IRQ's are bugging me 
>now :(. It's still NOT working. well i ran script and after 
>starting the "pcmcia" services it does not respond back, it does not 
>collect any errors . It seems like HardDisk is not responding back. So all 
>i can do at that point is take the power off and plug it back to restart 
>the machine. Kernel just stops working on me.
>If you have clue how the IRQ's are assigned by the linux kernel.
>          CPU0
>  0:      69250          XT-PIC  timer
>  1:       2184          XT-PIC  keyboard
>  2:          0             XT-PIC  cascade
>  8:          1             XT-PIC  rtc
>11:       8936          XT-PIC   eth0, i82365
>12:       6630          XT-PIC  PS/2 Mouse
>14:       9157          XT-PIC  ide0
>15:      20834          XT-PIC  ide1
>NMI:          0
>ERR:          0
>I have excluded all these above IRQ's in the 'config.opts" file. But Still 
>Does not work.
>Can i assign a static irq's to the hostap_cs driver. By modifying the 
>"config.opts" file. I don't really know what to do, it is kind of 
>frustating now!!
>FYI the bridge loads succesfully and but the card is giving the problem. I 
>can successfuly load the "orinoco" drivers but not the hostap_cs one ?? why
>If anyone out there have any clue please suggest.
>>From: Denis Vlasenko <vda at>
>>To: "gaurav dawra" <openapproject at>
>>Subject: Re: IRQ interrupt problem& HOSTAP
>>Date: Fri, 23 Jul 2004 00:16:49 +0300
>>On Thursday 22 July 2004 19:16, gaurav dawra wrote:
>> > Thanx denis.
>> >
>> > For loading Hostap i just need to start the cardmgr byu 
>> > start"
>> >
>> > What should i do after this, as the keyboard hangs and i could not able 
>> > do anything.
>>You should create a shell script:
>>echo "Going to start PCMCIA"
>>/etc/init.d/pcmcia start
>>sleep 2
>>echo "I will collect some data now. Reboot and examine /tmp contents"
>>cat /proc/interrupts >/tmp/ints
>>dmesg >/tmp/dmesg
>>echo "Ok you may reboot me now."
>>shutdown -r now
>>Just run it:
>># sh
>>and watch the fireworks :)
>FREE pop-up blocking with the new MSN Toolbar ? get it now! 
>HostAP mailing list
>HostAP at

Is your PC infected? Get a FREE online computer virus scan from McAfee? 

More information about the Hostap mailing list