DWL-520 trouble

Ka-Hing Cheung kahing
Sun Jul 18 16:26:47 PDT 2004

Sorry about getting back to you so late, I've been busy.

> Could you please try to find the exact location where this happens? I
> would appreciate it if you could try the attached patch and then load
> the module after reboot (without unloading it before reboot) in text
> console and see how long the initialization goest? You can apply this
> patch with
> patch -p0 < hostap_pci_debug.patch

Okay I tried that, the funny thing is, not only does it not crash,
everything works w/o me unloading the module before reboot (works ==
getting an IP). So I backed out the patch, and for some reason it
still works. I tried reboot after I got the IP from the router (so the
WEP module is also loaded), before that but with firmware loaded, and
w/o firmware loaded. I've not rebooted my box since last time I
emailed the list, and I don't think anything was changed (same
kernel/hostap). The modules are autoloaded by hotplug, as it always
had been...

I am not really understanding this... Could it be that I've loaded the
kernel orinoco driver and wlan-ng driver (not at the same time of
course), and somehow those drivers (actually wlan-ng is more likely,
since that was the one I tried before using hostap) messes up the
wireless card's state? Would it be helpful if I try to reboot to
hostap after loading wlan-ng's driver?


More information about the Hostap mailing list