hostap-0.1.3 not associate

jar jar
Mon Jul 12 16:49:10 PDT 2004


Box1: hostap-0.1.3 master mode, ch=13, no WEP, FW:1.5.6, kernel 
Box2: hostap-0.1.3 managed mode, ch=13, no WEP, FW:1.5.6, kernel 
2.6.6-1.435.2.3 (formerly: RH9/2.4.20)

Box1 and Box2 are running identical hardware.  When the Box1 was running 
with FC2 (2.6.6-1.435.2.3) and Box1 with RH9 (2.4.20) everything worked 
fine. Now I updated also the Box2 to FC2 (2.6.6-1.435.2.3). When e.g. 
the pcmcia system is restarted in Box1 (all related drivers 
unloaded/loaded) the Box2 can't associate any more as it did with RH9. 
With RH9 it associates almost immediately. After pcmcia restarting in 
Box2 it associates immediately.

But if I run "iwconfig wlan0 channel 1" in Box1, the Box2 associates 
immediately.  Then I can run "iwconfig wlan0 channel 13" to get it to 
wanted channel.

The only thing which has changed is the Linux distribution/kernel. Can 
anyone explain this behaviour ?

Best Regards, Jar

More information about the Hostap mailing list