Senao prism3 issues

Fri Jul 2 07:39:20 PDT 2004

Hi, i recently bought two different cards supposed to be Senao/prism. 
Both cards look similar (second has no logo), and have 2 (mmcx?) antenna 
connectors (and no builtin antenna). I am using them with an external 
small omni.

One is "NL-2511CD PLUS EXT2(E100)" Fcc id:"ni3-2511cd-plus3":
 product info: "INTERSIL", "HFA384x/IEEE", "Version 01.02", ""
   manfid: 0x0156, 0x0002
   wifi0: NIC: id=0x800c v1.0.0
   wifi0: PRI: id=0x15 v1.1.0
   wifi0: STA: id=0x1f v1.8.0

Second is (not listed as is in hostap_cs.conf) "NL-2511CD PLUS EXT2 
MERCURY (ETSI)" (has no fcc id!):
       product info: "WLAN", "11Mbps_PC-Card_3.0", "ISL37100P", "Eval-RevA"
       manfid: 0x000b, 0x7100
       wifi0: NIC: id=0x801b v1.0.0
       wifi0: PRI: id=0x15 v1.1.1
       wifi0: STA: id=0x1f v1.8.0
       (S/N found in pda does not match (by 2) the one printed in the 
small label (and includes a 0xa character!), so i guess someone flashed 
it bad)

Tried both in my laptop (knoppix 3.4 live) and desktop computer (debian 
sarge, 2.6.7 kernel, with a Texas Instruments PCI1410 adapter, hostap 
0.2.3) and I found all these issues with different card/firmware 

  *** Not working properly: Second card does not work properly, any 
operation (bringing down interface, changing mode, a client trying to 
associate) will not work, unless i download firmware (downloading 1.8.0 
firmware also solves it, though the card is supposed to have already the 
same version!!). In windows netstumbler does not work fine. I really 
need to download firmware before anything else.

Inserting the card:
    wifi0: Interrupt, but SWSUPPORT0 does not match: FFFF != 8A32 - card 
    wifi0: prism2_interrupt: ev=0xffff
    hostap_cs: CS_EVENT_CARD_REMOVAL
    wifi0: card already removed or not configured during shutdown
Trying to run kismet:
    wifi0: hfa384x_cmd: entry still in list? (entry=cf5feb04, type=0, res=0)
    wifi0: hfa384x_cmd: command was not completed (res=0, 
entry=cf5feb04, type=0, cmd=0x0002, param0=0x0000, EVSTAT=0000 INTEN=e09f)
    wifi0: reset port failed to disable port Setting monitor mode failed
    ... wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=-110, 
rid=fc00, len=2)
the message repeats...

I have to "prism2_srec ..." and "ifconfig wlan0 down up", then it works.

  *** Mac address mismatch:
       When using default firmware, both cards get this address 
00:60:B3:72:C3:25, instead of 00:02:6F:06:xx:xx or 00:02:6f:33:xx.xx. If 
I download any STA firmware (to ram) to any card the problem solves 
(even downloading 1.8.0 solves it!). I tried at least 1.5.6 and 1.8.0 
firmware versions from sydney wireless site.

  *** Antenna selection broken:
       Both cards have issues with antenna selection, no matter the 
firmware they are using. I made tests with another card and ping, 
tcpdump, iwlist ap... and it seems that:
       First card: antsel_rx is ok, like this:
            1 = diversity ? seems to receive no matter where the antenna 
is plugged
            2 = second antenna
            3 = first antenna

       Second card: antsel_TX affects RX !! in this way:
            1 = first antenna
            2 = second antenna
            3 = second antenna
       Both cards seem to always tx using second antenna, no matter what 
i tell them.
        I get this when changing tx or rx: wlan0 (WE) : Buffer for 
request SIOCGIWPRIV too small (16<88) with values of 16,32 and 64.

+++ Now i have some questions:
 - Do you think this is a card's issue, firmware, driver or what? Any 
suggestion for my problems?
 - Should i permanently flash the firmwares? A friend tried to flash a 
kind of the second card in windows and it got worse...
 - Is it possible to "upload" firmware from card to computer? It would 
be very interesting if i could do that.
 - Is there a site about prism firmware version issues? Should the Docs 
warn more about the pros/cons of upgrading?
 - I couldnt success in downloading Pri firmware (110 and 111) to ram, 
is it ok?

Thanks a lot for reading :)

More information about the Hostap mailing list