modprobe hostap_pci crash

Ben Hart ben.hart
Sun Aug 29 15:50:21 PDT 2004


I have a DWL-520 E1 card and have tried following Andrew Barr's "Using
the DWL-520 rev. E1 with HostAP"
<> instructions to
get the card up and running.

I have a 2.6.7 kernel with wireless extensions enabled.

I have disabled all other possible conflicting drivers: orinoco_pci,
etc. dmesg is clear of anything suspicious.

I have successfully compiled and installed:

I have downloaded the firmware and made the path changes needed in the
hostap_fw_load script.

I then try:
> modprobe hostap_pci

::wham:: The system completely freezes up.  I can't ssh in, switch to
a different tty or anything.  complete crash.  After a reboot all is
fine but try again and the same will happen.

unfortunatly, the crash happens right away and there isn't any output
from modprobe.

I have tried uninstalling (make uninstall) and reinstalling a few
times - no luck.  I have tried earlier versions of hostap (0.2.1 &
0.2.0).  with 0.2.1 I get the same crash.  I was unable to get the
0.2.0 installed, something about incorrect module type.

I've hit a wall here - can't seem to find any way to debug my way
through the problem.  I'll include some info about my system.  I hope
someone out there can give me some insights.

- Thanks!

My system:
  2.6.7-gentoo-r13 i686 AMD Athlon(tm) XP 3200+
  Shuttle AN35N-Ultra mother board.

lspci -v :

0000:01:07.0 Network controller: Intersil Corporation Prism 2.5
Wavelan chipset (rev 01)
        Subsystem: D-Link System Inc DWL-520 Wireless PCI Adapter, Rev E1
        Flags: bus master, medium devsel, latency 32, IRQ 12
        Memory at d2000000 (32-bit, prefetchable)
        Capabilities: [dc] Power Management version 2

More information about the Hostap mailing list