Problems making WPA work with ndiswrapper/broadcom

Jouni Malinen jkmaline
Wed Aug 18 20:52:39 PDT 2004

On Wed, Aug 18, 2004 at 03:33:31PM +0200, Kamil Iskra wrote:
> On Wed, Aug 18, 2004 at 06:27:56 -0400, Giridhar Pemmasani wrote:
> > You need to start dhclient/dhcpcd/pump (or whatever tool you use to
> > configure your interface) at the same time. Are you starting it?
> Would you mind explaining WHY you need to start it at the same time?  The
> channel is not authenticated then yet, so what could be the point of trying
> to send any data through it?  If it actually helps, then it would seem to
> me that there must be a race condition somewhere?

I don't see any need to start DHCP client at that time, but the
interface needs to be set up for wpa_supplicant to work. DHCP clients
are likely to do this, but then again, so does 'ifconfig <ifname> up'..
The DHCP client just better not set the interface down when it is

> I've reported something that looks like a similar problem, see my mail
> "wpa_supplicant does not work with a 3Com access point" sent on Jul 22
> (  Sadly, my
> report didn't elicit any response :-(.

Unfortunately, I have had a bit too limited amount of time to read,
never mind answer, all emails and the pending email queue has been
increasing steadily..

It looks like you were able to associate with the AP, so the issue looks
quite a bit different from the one in this email thread. Dropping of the
EAPOL-Start frame is expected with WPA-PSK. However, wpa_supplicant
debug log did not show any EAPOL-Key frames from the AP. I would like to
see a wireless sniffer log of this kind of problem to verify whether the
AP is actually sending out EAPOL-Key frames after association (in which
case the driver for ndiswrapper would be dropping the frames for some

I haven't tried Intel 2100 card with ndiswrapper, so I do not know what
to expect with it as far as WPA is concerned. Neither do a I have the
3Com AP you were using, so I cannot easily try to reproduce this with
another client card.

> I can add that I was a bit more successful with linuxant and a very old
> version of wpa_supplicant that I found on
>, apparently built from some
> alpha-version wpa_supplicant-lnxt2003121400.tar.gz.  According to
> wpa_supplicant, the authentication was successful, which is more than I
> could achieve with a more recent versions.  Alas, I could not send any
> packets via the authenticated channel, they would just disappear.  Perhaps
> there was simply an incompatibility between the recent version of linuxant
> I used and the old wpa_supplicant.  I tried wpa_supplicant 0.2.0 with
> linuxant, but it wouldn't authenticate, just like 0.2.3 or 0.2.4.  Sadly, I
> don't think I can repeat these experiments, because my trial linuxant key
> must have expired by now.

I'm not very interested in debugging old versions of wpa_supplicant, but
if the latest one does not work with Linuxant DriverLoader or
ndiswrapper, I would like to get debug logs and sniffer logs from the
failed cases. I do not have (nor have I ever tested) DriverLoader, so
debugging problems with that is going to rely on getting detailed
reports from others. I can test ndiswrapper more easily with various
cards, NDIS drivers, and APs.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list