Problem with 2.6.0-test9, linksys wpc 11 v3

Jon Nelson jnelson-hostap
Fri Nov 21 06:54:19 PST 2003

On Fri, 21 Nov 2003, Jouni Malinen wrote:

> On Mon, Nov 17, 2003 at 11:42:05AM -0600, Jon Nelson wrote:
> > Nov 15 16:07:04 workstation kernel: hostap_cs: CVS (Jouni Malinen <jkmaline at>)
> Have you tested with the latest stable release?

I don't think so.  When was it made?  What tag in CVS does it correspond

> > Nov 15 16:07:06 workstation kernel: wifi0: invalid skb->cb magic (0x00000000, expected 0xf08a36a2)
> Are you by any change trying to use wifi0 interface directly instead of

Not sure.  I'm using whatever the pcmcia stuff is told to use. I can
check to make sure, but I don't think I'm using wifi*.

> using wlan0? In other words, do you assign IP address to wifi0? If yes,
> please try wlan0.. wifi0 cannot be used directly, it is only used when
> the other interfaces are sending out IEEE 802.11 frames. You will
> probably still see that invalid magic message every now and then (e.g.,
> when sending ARP requests), but at least the connection is supposed to
> work. I'm using the CVS version with Linux 2.6.0-pre8 without problems.
> >  - results: I hate dlink, but hostap driver /did/ work with 2.4,
> >    appears like it /should/ with 2.6, but doesn't.

Thanks for the help!  I'll update to latest CVS and give that a try this
weekend.  If I see an obvious cvs tag in the logs, I'll try that,
perhaps, too.

> Did you try the same version of the driver that worked with 2.4?


> Or did you try the new version with 2.4?

Haven't tried that yet.

More information about the Hostap mailing list