Genesis Mode

Dustin Marquess jailbird
Tue Nov 4 19:13:12 PST 2003

Just downloaded the latest CVS copy of hostap.  Put the dead card in
and reset the machine.  No go, hostap_cs complains that the card
times out.  So I add no_primary=1 and get:

cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
hostap_crypt: registered algorithm 'NULL'
hostap_cs: CVS (Jouni Malinen <jkmaline at>)
divert: not allocating divert_blk for non-ethernet device wifi0
hostap_cs: Registered netdevice wifi0
hostap_cs: index 0x01: Vcc 3.3, irq 12, io 0x0100-0x013f
hostap_cs: assuming no Primary image in flash - card initialization not completed
wifi0: prism2_enable_aux_port - timeout - reg=0x8000
wifi0: trying to read PDA from 0x007f0000: OK
wifi0: prism2_enable_aux_port - timeout - reg=0xffff
wifi0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
wifi0: hfa384x_cmd_issue - timeout - reg=0x8a32
wifi0: hfa384x_cmd: entry still in list? (entry=c33cc580, type=0, res=-1)
wifi0: hfa384x_cmd: interrupted; err=-110
wifi0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd0b, len=8)
Could not get RID for component NIC
hostap_cs: Initialization failed
Unable to handle kernel NULL pointer dereference at virtual address 00000024
 printing eip:
*pde = 00000000
Oops: 0002 2.4.22aa1 #1 Sat Oct 18 15:11:11 CDT 2003
CPU:    0
EIP:    0010:[<c3077473>]    Not tainted
EFLAGS: 00010202
eax: 00000001   ebx: c13fb880   ecx: 00000001   edx: 00000001
esi: 00000000   edi: c2ca0604   ebp: 00000000   esp: c312bba0
ds: 0018   es: 0018   ss: 0018
Process cardmgr (pid: 62, stackpage=c312b000)
Stack: c13fb880 c13fb680 c13a4000 c13fb680 00000044 c01e5c53 00000004 00000000 
       c13fb6bc c307a5c0 00000000 00000000 c312bd74 c312bc50 c017e0b3 00000000 
       00000014 c01e88ae c02ebf80 00000014 00004000 00060000 00000001 00000000 
Call Trace:    [<c01e5c53>] [<c307a5c0>] [<c017e0b3>] [<c01e88ae>] [<c01e9c18>]
  [<c01e7061>] [<c3076b3e>] [<c307a5c0>] [<c30773d0>] [<c01e33d9>] [<c01e3f74>]
  [<c013deaf>] [<c0186f17>] [<c01875c2>] [<c017332f>] [<c01aa958>] [<c01a542b>]
  [<c01a6b84>] [<c01a8daf>] [<c01183fb>] [<c0115ac3>] [<c0129136>] [<c014563c>]
  [<c0151413>] [<c0129f3e>] [<c012a274>] [<c01e3a40>] [<c014ac2d>] [<c012a304>]
Modules: [(hostap_cs:<c3070060>:<c307a72c>)]
Code: c7 46 24 00 00 00 00 eb 94 8d 74 26 00 81 fa 00 20 00 00 0f

Not sure why cardmgr freaks the kernel out, but I'm not too worried.

I tried prism2_srec with the -r option and then with the -g option,
both errored out:

root at console:/home/jailbird# prism2_srec -v -g wifi0 ~jailbird/s1010701.hex 
S3 CRC-16 generation record: start=0x003F1800 len=52084 prog=1
Start address 0x00000000
srec summary for s1010701.hex
Component: 0x001f 1.7.1 (station firmware)
Supported platforms:
  0x8002 1.0.0,  0x8002 1.0.1,  0x8003 1.0.0,  0x8003 1.0.1,  0x8004 1.0.0
  0x8008 1.0.0
Interface compatibility information:
  role=Supplier variant=1 range=1-12 iface=Station Firmware-Driver (4)
  role=Actor    variant=1 range=1-1 iface=Modem-Firmware (1)
  role=Actor    variant=1 range=1-1 iface=Controller-Firmware (2)
  role=Actor    variant=1 range=1-2 iface=Primary Firmware-Driver (3)
Separate S3 data areas:
S3 area count: 3
  addr=0x003EE000..0x003EE069 (len=106)
  addr=0x003F1800..0x003FE373 (len=52084)
  addr=0x003FF000..0x003FFBE5 (len=3046)
Total data length: 55236
Start address 0x00000000

ioctl[PRISM2_IOCTL_HOSTAPD]: Connection timed out
Missing wlan component info
Could not read wlan RIDs

It looks like it's trying to work, but dies.  Should I take a lucky
guess that the PRI firmware is hosed and I need to get the card into
Genesis mode?

If that's the case, I might be crazy enough to try and rip the PCMCIA
card apart and try to fix it before I spend the money for a new card.
What pin on the hfa384x do I need to apply voltage?


Jouni Malinen <jkmaline at> wrote:
> On Tue, Nov 04, 2003 at 09:07:36AM -0600, Dustin Marquess wrote:
> > I tried using the DOS flash program to just download secondary
> > firmware to the card again, but I kept getting the "busy bit never
> > cleared" error, which I found in the archives about the PC card slot
> > modification.
> > 
> > I have a bad feeling that even though WinUpdate probably only
> > corrupted the STA firmware, I probably screwed-up the PRI image
> > trying to fix the card with the DOS flash program.
> Have you tried initializing the card with the latest Host AP driver
> version (with firmware upgrade enabled)? If only the STA image was
> corrupted, it should be possible to fix it without Genesis mode (well,
> unless the corrupted STA image is doing something horrible). However, if
> the PRI image is also corrupted, Genesis mode might be required..

More information about the Hostap mailing list