Problem with compiling hostap-driver-0.1.1.tar.gz

Jouni Malinen jkmaline
Sun Nov 2 15:54:29 PST 2003

On Sat, Nov 01, 2003 at 12:33:02AM +0100, Ingo Hoffmann wrote:

> I tried to compile hostap-driver-0.1.1.tar.gz on new SuSE 9.0 (kernel
> 2.4.21 with SuSE extensions) and got attached error message.
> The problem is obviously that there is a problem with the HZ macro,
> which has been changed in this kernel version (or in the according SuSE
> changes?).

SuSE has probably changed the HZ definition to be based on configuration
option or something similar and something is not included when compiling
external modules.. Could you tell me where I can download SuSE 2.4.21-99
kernel? I tried to find it from a mirror of SuSE ftp site, but it was
nowhere to be found (well, maybe in an ISO image or something, but I'm
not going to download 650 MB to get a look at one header file).

> I changed following two lines
> static int ap_max_inactivity[MAX_PARM_DEVICES] = { AP_MAX_INACTIVITY / 
> to
> static int ap_max_inactivity[MAX_PARM_DEVICES] = { 300, DEF_INTS };

I see nothing wrong in having HZ on that line, so I'm not going to
change that unless someone can show that this is really needed and the
correct fix.

> Here the the result of make pci:

Did you try compiling with just 'make'? This uses the kernel Makefile to
compile the module and whatever was done to HZ definition, has a better
change of working..

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list