More hostap weird behaviour

Benjamin Herrenschmidt benh
Thu Oct 17 08:17:57 PDT 2002

Hi !

I'm still trying to figure out what's wrong with hostap and
so have done more tests in various conditions, but couldn't
find some reasonable explanation for the results I'm getting.

First, did any of you already tried hostap on a big endian
platform (notably a PPC) ? Just in case....

The card is a Netgear MA401 updated to pri 1.1.0 and sta 1.4.9

I've done the following tests: (the tests in "Managed" mode are
done using an Apple airport card as the Master running Apple's
MacOS software base station). Using either channel 10 or 11

 - MA401 in "Master" mode in embedded box : nothing works. It
seems I can occasionally have a good packet and _sometimes_ the
test station gets properly authenticated, but that's quite rare.
I lost more than 90% of packets imho.

 - MA401 in "Managed" mode in embedded box : nothing works, it
doesn't manage to attach to the station

 - MA401 in "Master" mode in a desktop G4 PPC machine (an Apple
dual G4 SMP). In this config, I can usually attach to the master
from my test station (test station is an Apple airport) but an
overall transfer speed test using ftp barely gives 10 to 15Kbytes
per second, it seems most packets are dropped. Using dmesg, I
see that usually, ping packets only start going through after
the driver have reduced the TX speed to 1Mb/sec.

 - MA401 in "Managed" mode in a desktop G4 PPC. Here, it seems to
work a bit better. I can attach the the AP without too much problem,
then I do an ftp test and get about 50Kbytes/sec. (Note that
the nominal throughput of this test using 2 Apple airport cards,
one in linux with orinoco driver, one doing the AP in MacOS, is
about 500KBytes/sec). So it's still 1/10 of the speed it should
do. Using iwconfig, I see that it's never doing 11Mb/sec, it
starts at 2Mb/sec after a cor reset, but drops almost immediately
to 1Mb/sec as soon as I start transfering data

 - MA401 in "Managed" mode in an x86 PC. I got similar results
as above with the G4, though speed was double (about 100Kb),
but that may just be a side effect of better luck during

 - Same test as above, but with Windows XP instead of Linux,
using the driver provided by NetGear (despite the firmware not
matching what NetGear bundled, I tried downgrading to 1.3.4 from
netgear CD but this didn't work, WinUpdate just hung). Similar
results. It attaches to the network without much trouble, but
then, I see TX speed constantly oscillating and actual byte
throughput as well, for an average of about 100Kb/sec.

At this point, I gave up, I haven't been able to decide what's
really going on. I suspect there must be some power supply problem
on my embedded box making it not work at all, but still, the card
seems to be having problems. I'm wondering if either the 1.4.9
firmware is not good for that Netgear card, or if the card itself
is just defective (unfortunately, I don't have another one to test).

Did other people tested a Netgear MA401 (0x800c) with 1.4.9 fw ?
What kind of results did you get ?

Thanks for any tips/clues about what may be going on,


More information about the Hostap mailing list