W1A download issue

dinkypumpkin dinkypumpkin at gmail.com
Wed Apr 2 13:15:52 PDT 2014

On 02/04/2014 20:58, steve phillips wrote:
> Have tried to download episode 2 of W1A a few times over the last 5 days but not successful. Keep getting message "application provided invalid, non monotonically increasing dts to muxer in stream 1.....etc" Is there anything I can do or is it an issue in the bbc source file?

Not a source issue.  I'm sure I'm not the only one who downloaded it 
perfectly fine. The error message comes from ffmpeg, which means either 
that rtmpdump thinks the file downloaded OK when it didn't, or else 
there were some rtmpdump errors you didn't tell us about.  You probably 
got a duff download that you didn't delete, so you're feeding the same 
bad file repeatedly to ffmpeg.  Delete the .flv file and start over.

> Have used the --force --get commands to clear the partial flv file but still no joy

That won't remove a partial download.  You have to delete the .flv file 
from disk.

> PS running 2.82 on windows 7

That's a rather old version, which probably also means you have a rather 
old version of ffmpeg.  The handling of non-monotonic timestamps has 
changed in later versions of ffmpeg so that it doesn't automatically die 
in every case.

More information about the get_iplayer mailing list