I've got a few problems with get_iPlayer

Alexis Fotiadis alexisfotiadis at hotmail.com
Fri Aug 19 12:07:17 EDT 2011

On 19/08/11 14:14, Alexis Fotiadis wrote:
> I've been trying to post but keep getting:
> 'Your mail to 'get_iplayer' with the subject
>     I've got a few problems with get_iPlayer
> Is being held until the list moderator can review it for approval.
> The reason it is being held:
>      Message has a suspicious header
> Either the message will get posted to the list, or you will receive
> notification of the moderator's decision.  If you would like to cancel
> this posting, please visit the following URL:'
> I changed to Plain text and 80 column-width, but still doesn't work.
> What could be suspicious about the header?
> Is it because the message is too long? As I included some of the
> get_iPlayer output text for error messages. If so, should I attach the
> output as a .txt file?
> Any help much appreciated - my downloads haven't worked properly
> all week and I still can't figure out why..
> If you use a client like Thunderbird, it seems to work better. Plain 
> text utf8

Is Thunderbird for email? I'm on hotmail through Firefox..
Am attaching the main error output as a .txt file, see if it works 
better. If not will give Thunderbird a go, cheers for the tip.

First time I've posted here (had to re-post in Plain text as I think my 
previous was HTML, and therefore blocked), so just want to say thanks to 
all those keeping get_iPlayer working.

Several different errors keep disrupting my downloads, some of which may 
be from wireless or internet dropout, and one which definitely seems to 
be from rtmpdump. I have searched the forum (which solved earlier issues 
with rtmpdump 2.3, swf etc), but haven't found a solution for these.
patched get_iPlayer 2.79 (command line, not Web PVR) with rtmpdump 2.4
Windows XP Home 32bit .NET Framework SP3.5  
P4 3.2GHz 512MB RAM
Belkin N Wireless USB Adapters F5D8053 : V6000 (latest drivers)
O2 Wireless Broadband (0.5-3.5MBps)
get_iplayer --prefs-add --thumbnail --subtitles --modes=flashvhigh 
--whitespace --fatfilenames --output=C:\Documents_and_Settings
Alternatively I sometimes try  --modes=flashvhigh2
Cmd line:
get_iplayer --pid=b0xxxxxx
I assume the first error (see attached, Error 1) is from wireless or internet dropout, or from 
an adaptor problem. Sometimes my wireless adaptor turns itself off when 
get_iPlayer is running, but not with other programs like Firefox, Skype 
With rtmpdump 2.4 I can usually restart the download where it crashed, 
which never worked with 2.2 or 2.3.
Error 2:
The other error, which has started since I upgraded to rtmpdump 2.4 and 
is more disruptive, occurs when rtmpdump seems to 'overload' - according 
to TaskManager it starts using 1GB RAM (i.e. more than any other program 
running) then crashes, either by me closing it from TaskManager, or by 
itself in which case it takes other programs down with it. Since my 
laptop only has 512MB RAM, I'm not sure what's happening, but assume it's 
an issue with rtmpdump, not get_iPlayer. Also, it happens separately to 
parallel downloads i.e. only happens on one while the others still work.

(See attached, Error 2)

Another issue is .mp4 conversion of downloads before they've finished 
downloading, or failure part-way through conversion; I haven't got an 
error output text for either of these though.
Previously these problems seemed to be worse from 9am til around midnight, 
but worked smoother during the night, so I assumed they were all 
bandwidth/dropout issues. But over the last week I've only been able to 
fully download a couple of the shows I've tried. My internet seems much 
slower than usual, which means downloads don't have time to finish before 
they crash. I guess the rtmpdump-related error could be a bug in 2.4 as 
it's relatively recent.
Cheers for any help!

More information about the get_iplayer mailing list