[PATCH 1/2] nand: Add Marvell Orion NAND driver

Sebastian Hesselbarth sebastian.hesselbarth at gmail.com
Tue Aug 26 11:07:29 PDT 2014


On 08/26/2014 06:15 PM, Ezequiel Garcia wrote:
> On 26 Aug 04:09 PM, Sebastian Hesselbarth wrote:
>> On 08/23/2014 10:19 PM, Ezequiel Garcia wrote:
>>> This commit adds NAND support for the controller present in Kirkwood SoCs.
>>
>> I just did a quick check through all public MVEBU datasheets. It looks
>> like Kirkwood is really the only SoC with this specific IP while Dove,
>> Armada 370, and XP have a different one.
>>
> 
> Indeed. Dove's NAND controller seems to be NFC (aka NFC v1), which is
> probably similar to the one in PXA3xx. Armada 370/375/380/XP documents
> it as NFC v2. Both versions are similar enough to use the same pxa3xx-nand
> driver.
> 
> I plan to push support for NFCv2 only in Barebox.

Ok, I'll add NFCv1 differences when I find a way to easily boot barebox
on d{2,3}plug. AFAIKT, both lack UART boot mode switches like Cubox has.

> Regarding the so-called Orion driver, grepping Linux it seems the IP is
> used in Kirkwood and Orion5x.

Ach, silly me, I didn't check Orion5x FS because it is not available
on marvell.com. If it is the same IP, nand_orion.c of course *is* the
correct name. Sorry for the noise.

>>> Signed-off-by: Ezequiel Garcia <ezequiel.garcia at free-electrons.com>
>>> ---
>>>  drivers/mtd/nand/Kconfig      |   7 ++
>>>  drivers/mtd/nand/Makefile     |   1 +
>>>  drivers/mtd/nand/nand_orion.c | 162 ++++++++++++++++++++++++++++++++++++++++++
>>>  3 files changed, 170 insertions(+)
>>>  create mode 100644 drivers/mtd/nand/nand_orion.c
>>>
>>> diff --git a/drivers/mtd/nand/Kconfig b/drivers/mtd/nand/Kconfig
>>> index 04fe3c8..ccf1f9c 100644
>>> --- a/drivers/mtd/nand/Kconfig
>>> +++ b/drivers/mtd/nand/Kconfig
>>> @@ -90,6 +90,13 @@ config NAND_OMAP_GPMC
>>>  	  Support for NAND flash using GPMC. GPMC is a common memory
>>>  	  interface found on Texas Instrument's OMAP platforms
>>>
>>> +config NAND_ORION
>>> +	bool
>>> +	prompt "Orion NAND driver"
>>> +	depends on ARCH_MVEBU
>>
>> Therefore, we should limit this to ARCH_KIRKWOOD. Also, we could choose
>> to call the driver nand_kirkwood.c. OTOH, I am fine with Orion as long
>> as we find another good name for the other IP. Remember that Dove is
>> still kind-of-Orion.
>>
> 
> Sure, I'm fine with naming this nand-kirkwood.c and limit it to ARCH_KIRKWOOD
> to avoid confusion.

nand_orion.c is ok, but still we should limit it to ARCH_KIRKWOOD.

>> FWIW,
>>
>> Acked-by: Sebastian Hesselbarth <sebastian.hesselbarth at gmail.com>
>>
>> I'll give it a try on Guruplug later, too.
>>
> 
> Good. Any test is very well-received (although this one is almost a
> copy-paste from Linux, given it's really simple).
> 

Yeah, probably.

Sebastian



More information about the barebox mailing list