[PATCH 1/2] wifi: ath12k: extend the link capable flag
Karthikeyan Periyasamy
quic_periyasa at quicinc.com
Tue Apr 2 02:32:44 PDT 2024
On 4/1/2024 10:24 PM, Jeff Johnson wrote:
> On 3/28/2024 6:23 PM, Karthikeyan Periyasamy wrote:
>> Link capability categorized as Single Link Operation (SLO) and Multi Link
>> Operation (MLO).
>>
>> * Intra-chip SLO/MLO refers to links present within a chip
>> * Inter-chip SLO/MLO refers to links present across multiple chips
>
> Is "chip" the correct term?
>
> I'm thinking that this should be called "device" since that is the unit of
> hardware that is detected by a bus probe function and which is handled by a
> *device* driver.
>
> Doesn't this make more sense if the references to chip and SoC are changed to
> device?
>
In the QMI, SLO/MLO parameter exposed as chip only not device. So
followed the same terminology to avoid confusion for code readability.
struct wlfw_host_mlo_chip_info_s_v01 {
u8 chip_id;
u8 num_local_links;
u8 hw_link_id[QMI_WLFW_MAX_NUM_MLO_LINKS_PER_CHIP_V01];
u8 valid_mlo_link_id[QMI_WLFW_MAX_NUM_MLO_LINKS_PER_CHIP_V01];
};
struct qmi_wlanfw_host_cap_req_msg_v01 {
...
u8 mlo_num_chips;
u8 mlo_chip_info_valid;
struct wlfw_host_mlo_chip_info_s_v01
mlo_chip_info[QMI_WLFW_MAX_NUM_MLO_CHIPS_V01];
...
}
--
Karthikeyan Periyasamy
--
கார்த்திகேயன் பெரியசாமி
More information about the ath12k
mailing list