[PATCH 0/8] ath10k: refactor htt_rx path

Janusz Dziedzic janusz.dziedzic at tieto.com
Fri Mar 21 05:32:13 EDT 2014


This patchset remove htt_rx_info and intoduce usage
of ieee80211_rx_status template. Introduce calculation
split for per-ppdu and per-mpdu. Remove not needed
calculation we did before for each mpdu. Before we
did calculation for each mpdu and in case of heavy
traffic we could have eg. 15mpdus in one ppdu.

This ieee80211_rx_status template will be also required
to fix rates, rssi we will report to mac80211. I will
send this patches soon.

First two patches - no functional changes.

Tested on AP135, didn't notice any TP drop with this patchset.

Base on:
[PATCH 1/2] ath10k: add ath10k_htt_rx_amsdu_allowed function
[PATCH 2/2] ath10k: Fill per-ppdu info in rx_info only once
I send before.

Please review.

Janusz Dziedzic (8):
  ath10k: move rx related functions to htt_rx.c
  ath10k: rename process_rx_rates to ath10k_htt_rx_h_rates
  ath10k: introduce ieee80211_rx_status to htt_rx_info
  ath10k: setup rx channel per ppdu
  ath10k: kill not needed fields from htt_rx_info
  ath10k: return error when ath10k_htt_rx_amsdu_pop() fail
  ath10k: improve way we play with attention flags
  ath10k: finally kill htt_rx_info

 drivers/net/wireless/ath/ath10k/htt.h    |   18 +-
 drivers/net/wireless/ath/ath10k/htt_rx.c |  440 ++++++++++++++++++++----------
 drivers/net/wireless/ath/ath10k/txrx.c   |  183 -------------
 drivers/net/wireless/ath/ath10k/txrx.h   |    1 -
 4 files changed, 299 insertions(+), 343 deletions(-)

-- 
1.7.9.5




More information about the ath10k mailing list