[RFC 00/14] ath10k: Refactor rx path little bit
Janusz Dziedzic
janusz.dziedzic at tieto.com
Tue Mar 4 07:52:13 EST 2014
Refactor rx path, mainly split/reduce calculation we
did before. Now we caculate variable/flags only once
per-ppdu, while before we did some calculations for
each mpdu. Kill some not needed code and fill directly
ieee80211_rx_status structure.
TP veryfication required.
Janusz Dziedzic (14):
ath10k: add ath10k_htt_rx_amsdu_allowed function
ath10k: Fill per-ppdu info in rx_info only once
ath10k: move rx related functions to htt_rx.c
ath10k: rename process_rx_rates to ath10k_htt_rx_h_rates
ath10k: introduce ieee80211_rx_status to htt_rx_info
ath10k: kill signal field in htt_rx_info
ath10k: setup rx channel per ppdu
ath10k: kill rate substruct and tsf from htt_rx_info
ath10k: kill fcs_err from htt_rx_info
ath10k: kill mic_err/amsdu_more from htt_rx_info
ath10k: kill status from htt_rx_info
ath10k: kill encrypt_type from htt_rx_info
ath10k: return error when ath10k_htt_rx_amsdu_pop() fail
ath10k: improve way we play with attention flags
drivers/net/wireless/ath/ath10k/htt.h | 15 +-
drivers/net/wireless/ath/ath10k/htt_rx.c | 436 +++++++++++++++++++++---------
drivers/net/wireless/ath/ath10k/txrx.c | 183 -------------
drivers/net/wireless/ath/ath10k/txrx.h | 1 -
4 files changed, 308 insertions(+), 327 deletions(-)
--
1.7.9.5
More information about the ath10k
mailing list