compat-wireless-2014-05-22 breaks ath10k in an Archer C7 v2

Sven Schnelle svens at
Thu Jun 5 04:49:35 PDT 2014

Hi Kalle,

On 06/05/2014 01:36 PM, Kalle Valo wrote:
> Sven Schnelle <svens at> writes:
>> On 05/29/2014 09:48 AM, Michal Kazior wrote:
>>> +ath10k at
>>> On 28 May 2014 20:35, Andy Lutomirski <luto at> wrote:
>>>> It dies with 'otp calibration failed: 2'.
>>>> Some older version of the driver seemed to work fine.
>>> ath10k did not verify otp result before so it could load successfully
>>> despite errors.
>>> Someone raised this problem yesterday on IRC. I'm not really sure how
>>> we should deal with this properly.
>> I see the following output on the firmware console:
>> otp main...
>> Table initialized..
>> streamCnt 0
>> Golden Bin/fake Board Template used ...
>> otp done...
>> assertion failed? pc=0x948f19, line=5555, dump area=0x40ad04
>> Target ID: 0x4100016c (1090519404)
>> Debug Info:
>> 0x4100016c 0x000015b3 0x00948f19 0x00955b31
>> 0x00948f19 0x00060530 0x00000004 0x00000000
>> 0x00000000 0x004045f0 0x00404610 0x00955a00
>> 0x0000
>> However, the AP where OTP now fails is an engineering sample,
>> and probably doesn't contain any valid calibration. It did work
>> in the past, but with the latest ath10k the driver doesn't load
>> because of OTP failing. So maybe that output is helpful here.
> What we could do is add 'skip_otp' (or similar) module parameter,
> otp.bin is not run and then you just get the default calibration data.
Looking at the backtrace, can you tell whether the calibration data is 
the issue? I tried now with the firmware-2.bin and board.bin files from and
i'm getting the same error.


More information about the ath10k mailing list