[PATCH v2 1/4] ath10k: Add more details to some debug messages.

Kalle Valo kvalo at qca.qualcomm.com
Thu Feb 6 05:14:42 EST 2014

greearb at candelatech.com writes:

> From: Ben Greear <greearb at candelatech.com>
> ---

No s-o-b tag.

Also I would prefer style like this for patch titles (especially without
the double space after the colon):

ath10k: add more details to some debug messages

And thirdly :) please also CC linux-wireless for wider review audience

> --- a/drivers/net/wireless/ath/ath10k/mac.c
> +++ b/drivers/net/wireless/ath/ath10k/mac.c
> @@ -3418,7 +3418,8 @@ static void ath10k_flush(struct ieee80211_hw *hw, u32 queues, bool drop)
>  	if (ret <= 0 || skip)
> -		ath10k_warn("tx not flushed\n");
> +		ath10k_warn("tx not flushed, ret: %i  skip: %i  ar-state: %i\n",
> +			    ret, skip, ar->state);

I'm trying to keep warning and debug messages clean, maybe this is a bit
more readable:

"tx not flushed: %i (skip %i ar-state %i)\n"

Or another option:

"tx not flushed (skip %i ar-state %i): %i\n"

I would go for the latter.

Kalle Valo

More information about the ath10k mailing list