[tslib] Issue with tslib / QtQuick on yocto embedded linux

Martin Kepplinger martink at posteo.de
Thu Mar 15 05:17:13 PDT 2018

Am 15.03.2018 12:38 schrieb Sebastian Gonzalez:
> Hi,
> I just wanted to post an update...
> I managed to use tslib 1.15 in the target image. I replaced the name
> of the bitbake file on my host in
> /sources/meta-openembedded/meta-oe/recipes-graphics/tslib/ from
> "tslib_1.1.bb" to "tslib_1.15.bb" and updated the checksums in the
> bb-file.
> After that I ran bitbake again to build the target image.
> On the target system, with tslib 1.15, I could still see the negative
> values from ts_print when releasing touch. But now I was able to apply
> median filter, which solved my problem. After applying median filter
> there are no negative values any more for the x coordinate. So until
> now the Qt-App is responding to touch events as expected.
> Thank you Martin for your help!

Alright. Since I don't use yocto, could you push an update to the 
repo in question here?

Also, if you feel motivated, feel free to create an issue on github for 
tslib, with
your logs.



More information about the tslib mailing list