[Pcsclite-muscle] Alcor Micro AU9520 not recognized by libccid 1.4.31

Ludovic Rousseau ludovic.rousseau at gmail.com
Thu Nov 5 08:43:12 EST 2020

Le jeu. 5 nov. 2020 à 13:55, zeroconf <zeroconf at zeroconf.ee> a écrit :
> Hewllo!
> > Why do you want to downgrade libccid?
> > Previous versions of the CCID driver worked but the new versions do not work?
> That's true. My former experience: version 1.4.2-2 of libccid worked
> with that card reader. This was up to Ubuntu 18.04 and its based
> distros, like Lubuntu 18.04, etc. Couldn't get that old version
> anymore and all versions, I could get, didn't work.


> I include longer log - hopefully it gives more information.

Yes. It now contains what I was expecting.

> I
> experienced strange thing - booted computer up from scratch, started
> pcscd in debug mode, as you guided and voila - card reader worked!
> This is reflected in appropriate log*.txt included with current email.
> Certainly that debug mode required, that I stop the service in first
> place.

Maybe a delay is needed for the reader to boot or something like that.

> Checked dependencies manually, all were satisfied, installed fine, but
> still couldn't compile ccid driver from source - still complained,
> that configure: error: install pcsc-lite 1.8.3 or later, or use
> ./configure PCSC_CFLAGS=...
> ... which flags to use - have no idea...

Install the package libpcsclite-dev and try again.

> So, as init failed, obviously card reader is not working :(
> As you see, I restarted pscsd several times with hope, that card
> reader will start working.
> So, I'm stuck again...

But we are progressing.


 Dr. Ludovic Rousseau

More information about the pcsclite-muscle mailing list