[Pcsclite-muscle] IDBridge K3000 is not found by pcsc_scan

Ludovic Rousseau ludovic.rousseau at gmail.com
Thu Apr 19 05:31:37 PDT 2018

2018-04-19 13:35 GMT+02:00 Nikolaos Kakouros <nkak at kth.se>:
> Hello,


> I have a IDBridge K3000 device. I am trying to use it on either Arch Linux (fully updated) or Ubuntu 16.04.2 installed on a Dell laptop with an Intel i5 processor. I have tried with different USB ports. In both cases, I fail.
> On Arch Linux, I compiled the USB CCID driver from a fresh git checkout. The version of pcsc-lite is 1.8.23 and the version of pcsc-tools is 1.5.2.
> On Ubuntu 16.04, I used apt to install whatever is in the repos. So, pcsc-tools is 1.4.25, libccid is 1.4.22 and pcscd is 1.8.14. The output of pcscd --version is:
> pcsc-lite version 1.8.14.
> Copyright (C) 1999-2002 by David Corcoran <corcoran at musclecard.com>.
> Copyright (C) 2001-2011 by Ludovic Rousseau <ludovic.rousseau at free.fr>.
> Copyright (C) 2003-2004 by Damien Sauveron <sauveron at labri.fr>.
> Report bugs to <muscle at lists.musclecard.com>.
> Enabled features: Linux x86_64-pc-linux-gnu serial usb libudev usbdropdir=/usr/lib/pcsc/drivers ipcdir=/var/run/pcscd configdir=/etc/reader.conf.d
> Sorry for the sans serif font but if I include formatting the email bounces back.
> The device is recognized by the Linux kernel. The output of dmesg is:
> [ 4904.459100] usb 1-3: new high-speed USB device number 33 using xhci_hcd
> [ 4904.600782] usb 1-3: New USB device found, idVendor=08e6, idProduct=8140
> [ 4904.600784] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
> [ 4904.600786] usb 1-3: Product: IDBridge K3000
> [ 4904.600787] usb 1-3: Manufacturer: GEMALTO
> [ 4904.600788] usb 1-3: SerialNumber: C840357100001E52
> I run pcscd in debug mode (sudo LIBCCID_ifdLogLevel=0x000F pcscd --foreground --debug --apdu --color | tee log.txt). When the usb device is plugged in, it reacts and I see:
> 10516944 hotplug_libudev.c:651:HPEstablishUSBNotifications() USB Device add
> 00000176 hotplug_libudev.c:297:get_driver() Looking for a driver for VID: 0x08E6, PID: 0x8140, path: /dev/bus/usb/001/035
> 00000207 hotplug_libudev.c:651:HPEstablishUSBNotifications() USB Device add
> 00000137 hotplug_libudev.c:297:get_driver() Looking for a driver for VID: 0x08E6, PID: 0x8140, path: /dev/bus/usb/001/035
> The sudo ./src/parse utility shows:
> Parsing USB bus/device: 08E6:8140 (bus 1, device 35)
>  idVendor:  0x08E6  iManufacturer: GEMALTO
>  idProduct: 0x8140  iProduct: IDBridge K3000
>   NOT a CCID/ICCD device

The Gemalto IDBridge K3000 supported by the CCID driver has idProduct
0x8141 not 0x8140

> Am I doing sth wrong? Could there be sth wrong with the specific USB device I have? Can I somehow overcome this issue?

You have to enable the CCID mode on the K3000.
There should be a Windows tool to do that but I do not have it.


 Dr. Ludovic Rousseau

More information about the pcsclite-muscle mailing list