<html>
<head>
<meta content="text/html; charset=windows-1252"
http-equiv="Content-Type">
</head>
<body text="#000000" bgcolor="#FFFFFF">
Further to this, I have compiled trunk versions 47750 and 47458
which both exhibit the same IPv6 non-routing issue, however with
47458 the IPv6 address is a bit less b0rked...<br>
<br>
inet6 addr: xxxx:xxxx:xxxx:xxxx:xxxx:561e:7d31:631e%3/64
Scope:Global<br>
<br>
PING ipv6.google.com(sin04s05-in-x0e.1e100.net) 56 data bytes<br>
ping: sendmsg: Network unreachable<br>
ping: sendmsg: Permission denied<br>
ping: sendmsg: Network unreachable<br>
ping: sendmsg: Network unreachable<br>
ping: sendmsg: Network unreachable<br>
ping: sendmsg: Network unreachable<br>
^C<br>
--- ipv6.google.com ping statistics ---<br>
6 packets transmitted, 0 received, 100% packet loss, time 5022ms<br>
<br>
Some commits which caught my eye are the following:<br>
<br>
<meta http-equiv="content-type" content="text/html;
charset=windows-1252">
<p style="margin-bottom: 0cm; line-height: 100%">47514 47493 47487
47460/47459 & 47288<br>
</p>
<p style="margin-bottom: 0cm; line-height: 100%">Could be totally
wrong however and it could be a download during the compile
process that causes things to break...but so far I've spent the
whole day compiling and trying to narrow down what is causing IPv6
to not work.<br>
</p>
<p style="margin-bottom: 0cm; line-height: 100%">A build I did on
Oct 25, 2015 for revision 47245 works fine with IPv6.<br>
</p>
<p style="margin-bottom: 0cm; line-height: 100%">Note that I am
using Ubuntu 14.04.3 x64 to compile.<br>
</p>
<p style="margin-bottom: 0cm; line-height: 100%">Any help
appreciated<br>
</p>
<p style="margin-bottom: 0cm; line-height: 100%">TIA<br>
</p>
<p style="margin-bottom: 0cm; line-height: 100%">Adam<br>
</p>
<p style="margin-bottom: 0cm; line-height: 100%"><br>
</p>
<title></title>
<meta name="generator" content="LibreOffice 4.2.8.2 (Linux)">
<style type="text/css">
<!--
@page { margin: 2cm }
p { margin-bottom: 0.25cm; line-height: 120% }
-->
</style><br>
<br>
<div class="moz-cite-prefix">On 10/02/16 12:05, Adam Kuklycz wrote:<br>
</div>
<blockquote cite="mid:56BA8CC8.1090800@mcservices.com.au"
type="cite">Hi all,
<br>
<br>
I've noticed with current trunk (Designated Driver) and revisions
down to 48272 that IPv6 native does not work.
<br>
<br>
Infact when checking via ifconfig -a, on the pppoe-wan interface,
the IPv6 address ends up as follows:
<br>
<br>
inet6 addr: xxxx:xxxx:xxxx:xxxx:bd9f:ac2e:e659:67ee%2010362168/64
Scope:Global
<br>
<br>
I've attached the config file to this email that I used to
compile.
<br>
<br>
The /etc/config/network file is as follows:
<br>
<br>
root@rear-gw:~# cat /etc/config/network
<br>
<br>
config interface 'loopback'
<br>
option ifname 'lo'
<br>
option proto 'static'
<br>
option ipaddr '127.0.0.1'
<br>
option netmask '255.0.0.0'
<br>
<br>
config globals 'globals'
<br>
option ula_prefix 'fd10:bc2e:49e1::/48'
<br>
<br>
config interface 'lan'
<br>
option force_link '1'
<br>
option type 'bridge'
<br>
option proto 'static'
<br>
option netmask '255.255.255.0'
<br>
option ip6assign '64'
<br>
option dns '150.101.158.130'
<br>
option ipaddr '172.18.18.1'
<br>
option _orig_ifname 'eth0.1 wlan0 wlan0-1 wlan1'
<br>
option _orig_bridge 'true'
<br>
option ifname 'eth0.1'
<br>
<br>
config interface 'wan'
<br>
option proto 'pppoe'
<br>
option username '<a class="moz-txt-link-abbreviated" href="mailto:akuklycz@dynamic.internode.on.net">akuklycz@dynamic.internode.on.net</a>'
<br>
option password 'gc7qvhy8v'
<br>
option peerdns '0'
<br>
option dns '150.101.158.130'
<br>
option ifname 'eth0.2'
<br>
option ipv6 'auto'
<br>
<br>
config interface 'wan6'
<br>
option proto 'dhcpv6'
<br>
option dns '2001:44B8:41DC:FE00::3'
<br>
option peerdns '0'
<br>
option reqaddress 'try'
<br>
option reqprefix '64'
<br>
option ifname '@wan'
<br>
<br>
config switch
<br>
option name 'switch0'
<br>
option reset '1'
<br>
option enable_vlan '1'
<br>
<br>
config switch_vlan
<br>
option device 'switch0'
<br>
option vlan '1'
<br>
option ports '0t 2 3 4 5'
<br>
<br>
config switch_vlan
<br>
option device 'switch0'
<br>
option vlan '2'
<br>
option ports '0t 1'
<br>
<br>
root@rear-gw:~#
<br>
<br>
<fieldset class="mimeAttachmentHeader"></fieldset>
<br>
<pre wrap="">_______________________________________________
openwrt-devel mailing list
<a class="moz-txt-link-abbreviated" href="mailto:openwrt-devel@lists.openwrt.org">openwrt-devel@lists.openwrt.org</a>
<a class="moz-txt-link-freetext" href="https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel">https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel</a>
</pre>
</blockquote>
<br>
</body>
</html>