[RFC PATCH v2 0/1] Introduce UCI support for configuring DSA VLAN filter rules

Jo-Philipp Wich jo at mein.io
Thu Jul 23 02:53:13 EDT 2020


Hi,

> One thing which is a bit awkward as long as the bridge itself is
> configured as an interface, is that as far as I have understood,
> creating a tagged interface to the bridge requires first setting up an
> interface for the bridge, e.g. with protocol Unmanaged, and then
> setting up one or more vlan tagged interfaces on top of it which can
> then be configured with ip addresses.
The following configuration:

config interface foo
  option type bridge
  option ifname 'bar baz qrx'
  option proto ...

Is actually a convenience shortcut for:

config device
  option type bridge
  option name br-foo
  list ifname bar
  list ifname baz
  list ifname qrx

config interface foo
  option ifname br-foo
  option proto ...

So in order to define a bridge interface without IP configuration,
you could solely use:

config device
  option type bridge
  option name mybridge0
  list ifname lan1
  list ifname lan2
  ...

This has a couple of advantages:

 - You don't need a logical dummy interface
 - You can get rid of the implicit "br-" prefix
 - The resulting configuration becomes more explicit


Regards,
Jo

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.openwrt.org/pipermail/openwrt-devel/attachments/20200723/6ae35e2b/attachment-0001.sig>


More information about the openwrt-devel mailing list