[OpenWrt-Devel] dnsmasq not leasing after a while. Sometimes more than 5 times a day

Denis Periša darkman.hr at gmail.com
Mon May 27 07:03:33 PDT 2019


Yes, dnsmasq is still running but lease is not given.. I don't know how to
debug it more.
Configuration is simple, one subnet range 192.168.0.10 to 192.168.0.200 on
wlan0 interface for example. But it's not wifi issue, local also.
It sends mail as soon as error is detected and restarts dnsmasq after which
it works. Device is not rebooting.
 OpenWrt 18.06-SNAPSHOT, r7766-e9a7344550

Also my scripts checkes two times just to rule out false negative.
Also, more public exposure or none is pretty much same.. I have device
which gets maybe 1-2 person and one with 50 .. behaving same. After a while
it stops responding. Any more debug I could use somewhere?

On Mon, May 27, 2019 at 2:37 PM Vincent Wiemann <vincent.wiemann at ironai.com>
wrote:

> Hi Denis,
>
> I don't have such problems. Please post your configuration and device
> setup and try to
> get some logs. As far as I understand dnsmasq is unresponsible, but still
> runs?!
> What do you mean with "restart messages"? Are your devices rebooting?
>
> Regards,
>
> Vincent Wiemann
>
> On 27.05.19 13:43, Denis Periša wrote:
> > Hi all,
> >
> > This "bug" is following me for some time now.. a year at least. I'm
> hoping day after day that someone might find reason and fix it. I've set a
> script that checks dnsmasq and restarts it.
> >
> > -->
> >          if ! ( dhcping -q -h 00:99:99:99:99:99 -s 10.0.0.1 ) #Jos jedna
> provjera
> >                         then
> >                                 echo "DEAD dnsmasq! - `date` " >>
> /scripts/CRASH.log
> >                                 killall dnsmasq
> >                                 sleep 2
> >                                 dnsmasq;
> > .... .>.>>>> etc........... CUT ---
> >
> > two checks to be sure... and I get a lot of restart messages. different
> nodes.
> > I run this via cron every half hour.
> >
> > Anyone have similar problem?
> >
> > _______________________________________________
> > openwrt-devel mailing list
> > openwrt-devel at lists.openwrt.org
> > https://lists.openwrt.org/mailman/listinfo/openwrt-devel
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20190527/16455449/attachment.html>


More information about the openwrt-devel mailing list