[OpenWrt-Devel] [PATCH 1/2] procd: add docker support

Paul Spooren mail at aparcar.org
Thu May 23 09:57:09 PDT 2019


On 5/23/19 2:16 PM, Petr Štetiar wrote:
> Paul Spooren <mail at aparcar.org> [2019-05-23 13:36:37]:
>
>> No, thanks for the link. Seems that Docker now uses LXC anyway which
> No more[1] :-)
>
>  Remove LXC support.
>
>  The LXC driver was deprecated in Docker 1.8.  Following the deprecation
>  rules, we can remove a deprecated feature after two major releases. LXC won't
>  be supported anymore starting on Docker 1.10.
Oh sorry I'm losing track...
>> results in the availability of container=lxc in /proc/1/environ:
>>
>>     root at df9992e4c518:/# cat /proc/1/environ
>>    
>> HOSTNAME=df9992e4c518SHLVL=1HOME=/rootcontainer=lxcTERM=xtermPATH=/usr/sbin:/usr/bin:/sbin:/binPWD=/root at df9992e4c518:/#
> You're probably just using some already obsolete version of docker-ce.

Is it?

root at dawn:/home/a# docker -v
Docker version 18.09.6, build 481bc77

root at f62c16ac8fa3:/# ls -a .dockerenv
.dockerenv

root at f62c16ac8fa3:/# cat /proc/1/environ
HOSTNAME=f62c16ac8fa3SHLVL=1HOME=/rootcontainer=lxcTERM=xtermPATH=/usr/sbin:/usr/bin:/sbin:/binPWD=/

So I'm guessing replace .dockerinit with .dockerenv should do the job?

Best,
Paul



More information about the openwrt-devel mailing list