[OpenWrt-Devel] [PATCH] interface-ip: fix find locally addressable target for p2p

Tan Xiaofan xfan1024 at live.com
Fri May 17 10:27:00 PDT 2019


Hi

> Can you share the network config which requires this patch ?
> 
> Hans

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'iptun'
	option proto 'l2tp'
	option defaultroute '0'
	option server '192.168.100.1'   # l2tp server

config interface 'veth'
	option proto 'gretap'
	option ipaddr '10.255.255.100'  # iptun ipaddr
	option peeraddr '10.255.255.1'  # iptun peeraddr
	# option tunlink 'iptun'


More information about the openwrt-devel mailing list